Here is the tip of the day in case you are still wonder why your HTML5 code doesn’t work as expected in old browser e.g IE8 or below.

Add the following script to the of your markup to enable HTML5 support in old browser. We assume that you would like to support HTML5 web application using IE8. Since IE9 is HTML5 friendly, we can exclude the script by checking the current version of browser.